设为首页收藏本站返回主页

Ubuntu Kylin技术论坛

 找回密码
 立即注册
搜索
查看: 147|回复: 3

16.04 64位,安装qt4.8.6异常

[复制链接]

该用户从未签到

参加活动: 0

组织活动: 0

发表于 2017-1-7 11:11:04 | 显示全部楼层 |阅读模式
新手一个,遇到这个问题,请教大家啊?或者给个测试步骤命令!
./configure: 5152: ./configure: /home/lhg/qt-everywhere-opensource-src-4.8.6/config.tests/unix/compile.test: Permission denied
Basic XLib functionality test failed!
You might need to modify the include and library search paths by editing
QMAKE_INCDIR_X11 and QMAKE_LIBDIR_X11 in /home/lhg/qt-everywhere-opensource-src-4.8.6/mkspecs/linux-g++.
root@ubuntu:/home/lhg/qt-everywhere-opensource-src-4.8.6# sudo apt-get install libxext-dev libxfixes-dev libxfont-dev libxft-dev
正在读取软件包列表... 完成
正在分析软件包的依赖关系树      
正在读取状态信息... 完成      
libxext-dev 已经是最新版 (2:1.3.3-1)。
libxfixes-dev 已经是最新版 (1:5.0.1-2)。
libxfont-dev 已经是最新版 (1:1.5.1-1)。
libxft-dev 已经是最新版 (2.3.2-1)。



回复

使用道具 举报

  • TA的每日心情
    开心
    5 天前
  • 签到天数: 37 天

    [LV.5]常住居民I

    参加活动: 0

    组织活动: 0

    发表于 2017-1-7 19:06:56 | 显示全部楼层
    你这个从你的截图看/你是下载的源码包/你只是做了第一步检测环境/这里英文显示检测你的XLib 失败/让你从新设定/
    另外:看你的终端截图你是在用root权限运行/不建议用者权限编译源码包/建议用普通用户名义/直到最后安装
    才利用权限
    sudo make install
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    开心
    5 天前
  • 签到天数: 37 天

    [LV.5]常住居民I

    参加活动: 0

    组织活动: 0

    发表于 2017-1-7 19:25:35 | 显示全部楼层
    你是在这里下载的对吧?



    到这个页面有详细的安装指导
    http://qt.apidoc.info/4.8.5/qt-embedded-install.html

    本帖子中包含更多资源

    您需要 登录 才可以下载或查看,没有帐号?立即注册

    x
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    开心
    5 天前
  • 签到天数: 37 天

    [LV.5]常住居民I

    参加活动: 0

    组织活动: 0

    发表于 2017-1-7 20:30:31 | 显示全部楼层
    第一步:下载https://download.qt.io/archive/qt/4.8/4.8.2/
    第二部:解压
    cd (进入你文件下载存放所在绝对路径)
    1. gunzip qt-everywhere-opensource-src-4.8.2.tar.gz
    复制代码
    1. tar xf qt-everywhere-opensource-src-4.8.2.tar
    复制代码
    1. cd qt-everywhere-opensource-src-4.8.2/
    复制代码
    这部检测安装环境如果缺少依赖要sudo apt-get install 安装全依赖注意看检测后终端提示:
    1. ./configure
    复制代码
    :首先终端会提示:
    Which edition of Qt do you want to use ?

    Type 'c' if you want to use the Commercial Edition.
    Type 'o' if you want to use the Open Source Edition.
    #翻译过来就是
    你想使用哪个版本的Qt?

    如果要使用商业版,请键入“c”。
    如果要使用开源版,请键入'o'。

    #这里我个人建议输入o选择开源,如果你愿意花钱可以选择c输入
    #输入o以后开始执行检测环境
    #终端会接着提示
    This is the  Open Source Edition.

    You are licensed to use this software under the terms of
    the Lesser GNU General Public License (LGPL) versions 2.1.
    You are also licensed to use this software under the terms of
    the GNU General Public License (GPL) versions 3.

    Type '3' to view the GNU General Public License version 3.
    Type 'L' to view the Lesser GNU General Public License version 2.1.
    Type 'yes' to accept this license offer.
    Type 'no' to decline this license offer.

    Do you accept the terms of either license?

    #翻译过来就是
    这是开源版。

    您已获得根据条款使用本软件的许可
    较宽松GNU通用公共许可证(LGPL)2.1版。
    您还根据许可的条款使用本软件
    GNU通用公共许可证(GPL)版本3。

    键入'3'以查看GNU通用公共许可证版本3。
    键入“L”以查看Lesser GNU通用公共许可证版本2.1。
    输入“yes”接受此许可证提供。
    输入“no”拒绝此许可证提供。

    #这里你可以输入yes 确认进入开始
    1. yes
    复制代码
    #漫长的检测环境工作大概需要15----20分钟
    #如果你的环境没有提示no,所有的环境条件符合终端接下来会提示
    Qt is now configured for building. Just run 'make'.
    Once everything is built, you must run 'make install'.
    Qt will be installed into /usr/local/Trolltech/Qt-4.8.2

    To reconfigure, run 'make confclean' and 'configure'.

    #翻译过来就是
    Qt现在配置为建设。 只是运行'make'。
    一旦一切建立,你必须运行“make install”。
    Qt将安装到/usr/local/Trolltech/Qt-4.8.2

    要重新配置,请运行“make confclean”和“configure”。

    #接下来你可以进入下一环节编译终端输入
    1. make
    复制代码
    #编译工作更是漫长大概需要45----60分钟等着一切都结束了你可以执行最后的安装/终端这次输入
    1. sudo make install
    复制代码
    #这些结束后你的程序就安装完成了,找到你的程序可以启动使用:
    最后祝你好运,
    如果这样详细你还不能安装那你不适合使用linux程序,回到windows视窗下面吧,哪里有双击的exe傻瓜操作,可是你什么也不会得到,因为你所学习的他都帮助你做了,也就是所有人长久养成了,温室花朵,什么都不会,一点常识也没有!!!




    回复 支持 反对

    使用道具 举报

    您需要登录后才可以回帖 登录 | 立即注册

    本版积分规则

    Archiver|手机版|小黑屋|Ubuntu Kylin    

    GMT+8, 2017-1-21 02:05 , Processed in 0.042452 second(s), 26 queries .

    Powered by Discuz! X3.2

    © 2001-2013 Comsenz Inc.

    快速回复 返回顶部 返回列表