设为首页收藏本站返回主页

Ubuntu Kylin技术论坛

 找回密码
 立即注册
搜索
查看: 84|回复: 3

【求助】按照教程安装wineqq失败

[复制链接]
  • TA的每日心情
    擦汗
    2017-1-13 09:27
  • 签到天数: 2 天

    [LV.1]初来乍到

    参加活动: 0

    组织活动: 0

    发表于 2017-1-11 11:19:18 | 显示全部楼层 |阅读模式
    本帖最后由 takumi2088 于 2017-1-11 11:23 编辑

    安装wine qq提示依赖关系问题,运行代码取消依赖后再安装依然提示
    (本人win7下虚拟机安装16.04(64bit)后安装qq没问题,但在真机上就出现这问题了,UbuntuKylin版本一样)


    终端代码如下:

    takumi@Ubuntu-PC:~/00-Software/wine-qqintl$ sudo dpkg -i fonts-wqy-microhei_0.2.0-beta-2_all.deb ttf-wqy-microhei_0.2.0-beta-2_all.deb wine-qqintl_0.1.3-2_i386.deb
    [sudo] takumi 的密码:
    正在选中未选择的软件包 fonts-wqy-microhei。
    (正在读取数据库 ... 系统当前共安装有 178812 个文件和目录。)
    正准备解包 fonts-wqy-microhei_0.2.0-beta-2_all.deb  ...
    正在解包 fonts-wqy-microhei (0.2.0-beta-2) ...
    正在选中未选择的软件包 ttf-wqy-microhei。
    正准备解包 ttf-wqy-microhei_0.2.0-beta-2_all.deb  ...
    正在解包 ttf-wqy-microhei (0.2.0-beta-2) ...
    正在选中未选择的软件包 wine-qqintl:i386。
    正准备解包 wine-qqintl_0.1.3-2_i386.deb  ...
    正在解包 wine-qqintl:i386 (0.1.3-2) ...
    正在设置 fonts-wqy-microhei (0.2.0-beta-2) ...
    正在设置 ttf-wqy-microhei (0.2.0-beta-2) ...
    dpkg: 依赖关系问题使得 wine-qqintl:i386 的配置工作不能继续:
    wine-qqintl:i386 依赖于 libasound2.
    wine-qqintl:i386 依赖于 libgtk2.0-0.
    wine-qqintl:i386 依赖于 liblcms2-2.
    wine-qqintl:i386 依赖于 libpng12-0.
    wine-qqintl:i386 依赖于 libsm6.
    wine-qqintl:i386 依赖于 libncurses5.
    wine-qqintl:i386 依赖于 libcups2.
    wine-qqintl:i386 依赖于 libpulse0.
    wine-qqintl:i386 依赖于 libmpg123-0.
    wine-qqintl:i386 依赖于 libasound2-plugins.

    dpkg: 处理软件包 wine-qqintl:i386 (--install)时出错:
    依赖关系问题 - 仍未被配置
    正在处理用于 fontconfig (2.11.94-0ubuntu1) 的触发器 ...
    正在处理用于 gnome-menus (3.13.3-6ubuntu3.1) 的触发器 ...
    正在处理用于 desktop-file-utils (0.22-1ubuntu5) 的触发器 ...
    正在处理用于 bamfdaemon (0.5.3~bzr0+16.04.20160701-0ubuntu1) 的触发器 ...
    Rebuilding /usr/share/applications/bamf-2.index...
    正在处理用于 mime-support (3.59ubuntu1) 的触发器 ...
    正在处理用于 hicolor-icon-theme (0.15-0ubuntu1) 的触发器 ...
    在处理时有错误发生:
    wine-qqintl:i386
    takumi@Ubuntu-PC:~/00-Software/wine-qqintl$ sudo apt-get install -f
    正在读取软件包列表... 完成
    正在分析软件包的依赖关系树      
    正在读取状态信息... 完成      
    正在修复依赖关系... 完成
    下列软件包将被【卸载】:
      wine-qqintl:i386
    升级了 0 个软件包,新安装了 0 个软件包,要卸载 1 个软件包,有 1 个软件包未被升级。
    有 1 个软件包没有被完全安装或卸载。
    解压缩后将会空出 199 MB 的空间。
    您希望继续执行吗? [Y/n] y
    (正在读取数据库 ... 系统当前共安装有 180093 个文件和目录。)
    正在卸载 wine-qqintl:i386 (0.1.3-2) ...
    正在处理用于 hicolor-icon-theme (0.15-0ubuntu1) 的触发器 ...
    正在处理用于 gnome-menus (3.13.3-6ubuntu3.1) 的触发器 ...
    正在处理用于 desktop-file-utils (0.22-1ubuntu5) 的触发器 ...
    正在处理用于 bamfdaemon (0.5.3~bzr0+16.04.20160701-0ubuntu1) 的触发器 ...
    Rebuilding /usr/share/applications/bamf-2.index...
    正在处理用于 mime-support (3.59ubuntu1) 的触发器 ...
    正在处理用于 libc-bin (2.23-0ubuntu3) 的触发器 ...

    回复

    使用道具 举报

  • TA的每日心情
    开心
    昨天 11:22
  • 签到天数: 21 天

    [LV.4]偶尔看看III

    参加活动: 0

    组织活动: 0

    发表于 2017-1-11 13:18:03 | 显示全部楼层
    我的也是装不上,我用的是16.04LTS版。
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    参加活动: 0

    组织活动: 0

    发表于 6 天前 | 显示全部楼层
    我的也是这样。 不是虚拟机里面的,也出问题了。
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    慵懒
    昨天 15:36
  • 签到天数: 2 天

    [LV.1]初来乍到

    参加活动: 0

    组织活动: 0

    发表于 前天 21:05 | 显示全部楼层

    我按教程,最后成功了。

    本帖最后由 shinyhero 于 2017-1-19 21:30 编辑

    感觉有几个要点,
    首先得搞清楚自己的ubantu系统是不是在1610之后,如果缺少libpng12这个包,就先把这个按教程安上。
    其次,QQ要下对地址http://www.ubuntukylin.com/application/show.php?lang=cn&id=279,我引用一下其他帖的内容
    下载后解压得[url=]U[/url]到wine-qqintl文件夹,里面有三个deb包:fonts-wqy-microhei_0.2.0-beta-2_all.deb、ttf-wqy-microhei_0.2.0-beta-2_all.deb、wine-qqintl_0.1.3-2_i386.deb

    安装:(在64位系统中应注意输入sudo apt-get install libgtk2.0-0:i386  解决依赖性关系,可以用cat /etc/issue 查看系统位数
    1、在wine-qqintl目录下打开终端输入:sudo dpkg -i fonts-wqy-microhei_0.2.0-beta-2_all.deb ttf-wqy-microhei_0.2.0-beta-2_all.deb wine-qqintl_0.1.3-2_i386.deb
    2、如果报依赖错误,输入:sudo apt-get install -f
    3、自动解决依赖后再执行步骤1

    另外需要注意的是:在登录的时候,如果输入密码时提示密码错误,请使用旁边的软件盘进行鼠标点击输入就能成功了。
    是在自己的笔记本上登录,下次补上台式机上的运行截图
    回复 支持 反对

    使用道具 举报

    您需要登录后才可以回帖 登录 | 立即注册

    本版积分规则

    Archiver|手机版|小黑屋|Ubuntu Kylin    

    GMT+8, 2017-1-21 02:07 , Processed in 0.033511 second(s), 29 queries .

    Powered by Discuz! X3.2

    © 2001-2013 Comsenz Inc.

    快速回复 返回顶部 返回列表