Ubuntu Kylin技术论坛

 找回密码
查看: 153|回复: 4

安装odbc17驱动和sqlcmd失败

[复制链接]
  • TA的每日心情

    2016-4-26 11:23
  • 签到天数: 3 天

    [LV.2]偶尔看看I

    发表于 2020-6-5 08:58:46 | 显示全部楼层 |阅读模式
    我想要在系统中安装linux下的sqlserver,成功了

    然后想要进一步安装驱动和sqlcmd应用,失败了
    就是运行这个的时候:
    sudo apt-get install mssql-tools unixodbc-dev
    提示:E: 无法定位软件包 mssql-tools


    下列软件包有未满足的依赖关系:
    mssql-tools : 依赖: msodbcsql17 (>= 17.3.0.0) 但是它将不会被安装
    unixodbc-dev : 依赖: unixodbc (= 2.3.7)
                    依赖: odbcinst1debian2 (= 2.3.7) 但是它将不会被安装
    E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系


    现在不知道怎么办了,help!


    安装参考:

    https://docs.microsoft.com/zh-cn ... 5#microsoft-odbc-17


    回复

    使用道具 举报

  • TA的每日心情
    奋斗
    4 天前
  • 签到天数: 5 天

    [LV.2]偶尔看看I

    发表于 2020-6-8 09:20:16 | 显示全部楼层
    先试试 sudo apt --fix-broken install
    回复 支持 反对

    使用道具 举报

  • TA的每日心情

    2016-4-26 11:23
  • 签到天数: 3 天

    [LV.2]偶尔看看I

     楼主| 发表于 2020-6-10 08:29:10 | 显示全部楼层
    老二次元了 发表于 2020-6-8 09:20
    先试试 sudo apt --fix-broken install

    是 -f 修复参数吗?你的命令不识别。
    不过直接-f 修复后也是一样的。
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    奋斗
    4 天前
  • 签到天数: 5 天

    [LV.2]偶尔看看I

    发表于 2020-6-11 16:58:55 | 显示全部楼层
    xndd 发表于 2020-6-10 08:29
    是 -f 修复参数吗?你的命令不识别。
    不过直接-f 修复后也是一样的。

    我试了试貌似没有mssql-tools这个软件包呢
    回复 支持 反对

    使用道具 举报

  • TA的每日心情

    2016-4-26 11:23
  • 签到天数: 3 天

    [LV.2]偶尔看看I

     楼主| 发表于 2020-6-11 17:00:13 | 显示全部楼层
    是微软的,但是连接不上,你看看我的帖子链接。
    或者有其他安装方式?现在我是安装好了mssqlserver,但是sqlcmd就是不行。
    回复 支持 反对

    使用道具 举报

    您需要登录后才可以回帖 登录 | 立即注册

    本版积分规则

    小黑屋|手机版|Archiver|Ubuntu Kylin    

    GMT+8, 2020-7-6 04:18 , Processed in 0.020199 second(s), 17 queries .

    Copyright ©2013-2020 Ubuntu Kylin. All Rights Reserved .

    ICP No. 15002470-2 Tianjin

    快速回复 返回顶部 返回列表