优麒麟技术论坛

 找回密码

peony-extensions 在处理时有错误发生 [复制链接]

Ubuntu Kylin 22.04 AMD64

准备解压 .../peony-extensions_3.2.3-1_amd64.deb  ...

正在解压 peony-extensions (3.2.3-1) 并覆盖 (3.2.2) ...
dpkg: 处理归档 /var/cache/apt/archives/peony-extensions_3.2.3-1_amd64.deb (--unpack)时出错:
正试图覆盖 /usr/lib/x86_64-linux-gnu/peony-extensions/libpeony-bluetooth-plugin.so,它同时被包含于软件包 peony-bluetooth 3.2.2
在处理时有错误发生:
/var/cache/apt/archives/peony-extensions_3.2.3-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


发表于 2021-10-29 15:59:29
回复

使用道具 举报

peony-extensions 在处理时有错误发生 [复制链接]

应该是软件更新以后的冲突问题,强制安装或者是卸载有冲突的,我记得之前也有一次会这样
发表于 2021-11-1 02:49:59
回复

使用道具 举报

peony-extensions 在处理时有错误发生 [复制链接]

熟悉的陌生人 发表于 2021-11-1 02:49
应该是软件更新以后的冲突问题,强制安装或者是卸载有冲突的,我记得之前也有一次会这样

有没有可能是多个软件源仓库共用造成的?优麒麟给 20.04 添加了额外专有的 UKUI 仓库。

 楼主| 发表于 2021-11-1 08:56:11
回复

使用道具 举报

peony-extensions 在处理时有错误发生 [复制链接]

chipo 发表于 2021-11-1 08:56
有没有可能是多个软件源仓库共用造成的?优麒麟给 20.04 添加了额外专有的 UKUI 仓库。

不应该的,应该是软件升级的时候包的结构变了导致的
发表于 2021-11-3 16:37:04
回复

使用道具 举报

小黑屋|Ubuntu Kylin    

GMT+8, 2021-12-1 11:35 , Processed in 0.019362 second(s), 20 queries .

Copyright ©2013-2021 Ubuntu Kylin. All Rights Reserved .

ICP No. 15002470-2 Tianjin

快速回复 返回顶部 返回列表