优麒麟技术论坛

 找回密码

ubuntukylin 20.4如何安装libcurl3! [复制链接]

安装一个浏览器需要libcurl3依赖,可是安装时候提示与libcurl4冲突,不能安装,结果导致浏览器一直安装不上。其他3个依赖已经安装完成,就是这个libcurl3搞不定,请各位指教一下!已经试了几种方法了都不行啊。

发表于 2022-1-9 16:54:40
回复

使用道具 举报

ubuntukylin 20.4如何安装libcurl3! [复制链接]


问题情况如图。顺便说一下,该系统都到这个版本了,还有这么多的依赖没搞好,困难好大哦!



本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
 楼主| 发表于 2022-1-9 16:58:32
回复

使用道具 举报

ubuntukylin 20.4如何安装libcurl3! [复制链接]

先安装一下aptitude包,然后使用sudo aptitude install 包名,在解决方案里降级一些包试试看?
发表于 2022-1-10 09:14:47
回复

使用道具 举报

ubuntukylin 20.4如何安装libcurl3! [复制链接]

libcurl3和libcurl4不能兼容,20.04上面系统依赖的是libcurl4,想降级是比较难的,试试强装浏览器如何?

sudo dpkg -i  xxx.deb
发表于 2022-1-10 10:34:41
回复

使用道具 举报

ubuntukylin 20.4如何安装libcurl3! [复制链接]

这个问题主要是浏览器给的依赖版本太低了,没有适配而已,不是系统的问题
发表于 6 天前
回复

使用道具 举报

小黑屋|优麒麟    

GMT+8, 2022-1-19 12:01 , Processed in 0.020830 second(s), 18 queries .

Copyright ©2013-2022 Ubuntu Kylin. All Rights Reserved .

ICP No. 15002470-2 Tianjin

快速回复 返回顶部 返回列表