Ubuntu Kylin技术论坛

 找回密码
查看: 14724|回复: 6

Ubuntu下完美使用QQ8.1,比Longene QQ更稳定

[复制链接]
  • TA的每日心情
    奋斗
    2017-7-17 09:20
  • 签到天数: 27 天

    [LV.4]偶尔看看III

    发表于 2016-8-18 14:01:33 | 显示全部楼层 |阅读模式
    本帖最后由 Find 于 2016-8-18 14:09 编辑

    Introduction
    本文主要介绍了如何在Linux上完美运行deepin团队维护的wine下的一些软件。比如QQ等。这个方法运行的QQ基本没有bug,而且比广泛流行的qq国际版(实际上也是deepin团队的作品)版本更新,且功能更多,比longene社区的QQ(bug实在太多了)要稳定很多。
    原文地址  
    Linux完美使用deepin QQLinux、chrome运行安卓app

    1. Linux运行QQ
    我们知道在linux上面,deepin做了很多wine的应用程序,但是在其他的linux发行版上却没有这种待遇,下面介绍一下,如何在继续debian的linux发行版上运行deepin的wine应用程序。
    测试通过的平台:
    Mint 17.3(crossover14),Ubuntu 16.04(crossover 15),Debian8(crossover 14 && 15)
    注:此文章所提及的内容纯属个人兴趣,可以一起交流但不得用于非法途径,使用过程中出现的问题与本人无关
    deepin的wine应用是基于crossover运行的,但是我试了移植到playOnLinux上基本没多少问题,但是考虑到安装比较麻烦还是使用了crossover。
    ( Linux)将CrossOver的wine程序移植到PlayOnLinux: http://www.cnblogs.com/xuelongqy/p/5438405.html
    如果支持crossover的朋友请购买正版。
    下文皆以Debian8 Gnome3 x64为例
    1.1 安装crossover
    crossover百度网盘下载
    注:资源文件夹里面有多个版本的crossover,后缀加了free你们懂的,但是存在部分功能性问题,不影响deepinwine的软件包使用。没有free的没有功能性问题,但是可能出现deepinwine软件兼容性问题,试用15天的,如果支持crossover的朋友请购买正版。建议大家来回覆盖安装这两个版本使用,基本可以互补。如果有兴趣的朋友可以和我一起讨论研究解决问题。
    对于什么是来回覆盖安装,举个例子:free版是不能创建容器的,那么我们先安装不是free的版本也就是试用版,把容器创建好了以后,在覆盖安装free版就可以使用了。所以两个版本功能是互补的,虽然麻烦,但还是不影响正常使用的。
    1.1.1 添加32位库的支持
    如果是64位系统,先添加对32位库的支持:
    sudo dpkg --add-architecture i386sudo apt-get update# 可能需要添加下列32位库sudo apt-get install lib32z1 lib32ncurses51.1.2 安装crossover
    如果要安装14版本,
    从上面的分享地址里下载crossover_14.1.11-1_all.deb crossover_14.1.11-1_all-free.deb deepin-crossover_0.5.14_all.deb三个文件。依次安装
    如果安装15,
    crossover-15_15.0.3-1_all.deb crossover-15_15.0.3-1_all-free.deb deepin-crossover-helper_1.0deepin0_all.deb 并依次安装。
    1.1.3 可能出现的依赖问题
    • debian 8 可能会出现依赖问题,需要安装libjpeg8但是库里没有,这是因为这个包在testing分支里,stable是没有的,但是可以直接下载deb包安装
    • 如果crossover不能使用(不能创建容器),安装libp11-kit-gnome-keyring_3.18.3-0ubuntu2_i386.deb,还是不能的话的试试64位版的
    • 其他依赖问题:
      • 如果安装过程中缺少依赖不能安装,可以参照后面移植的方法去掉相关依赖,影响不大
      • 如果可以安装libgnutls-deb0-28的话就安装,不能安装也没多大影响。
      • 安装libgif4,安装不了的,可以安装libgif7,比如ubuntu16
      • 以上依赖包可以通过新立得安装,也可以使用”sudo apt-get install 软件名 “安装

    1.2 安装deepin的wine程序
    都是deb包,可以直接下载安装。
    2. 简单移植deepin的wine软件包道其他Linux发行版
    对于无法解决的依赖,可以直接对软件包进行修改,去掉这些依赖进行安装,但由于依赖问题,所以部分软件并不能完美运行。
    2.1 安装dpkg
    默认已经安装
    sudo apt-get install dpkg2.2 修改deepin的wine软件包
    下载deepin的wine软件包,例如wine.deb,
    2.2.1 解压wine软件包# 先创建软件包目录mkdir -p extract/DEBIAN# 用dpkg解压dpkg-deb -x wine.deb extract/dpkg-deb -e wine.deb extract/DEBIAN2.2.2 去掉依赖
    用文本编辑器打开extract/DEBIAN/control,找到Depends行,去掉安装时,提示的不能通过的依赖,一般只留下crossover即可。
    2.2.3 重新打包# 建立软件包生成目录mkdir build# 重新打包dpkg-deb -b extract/ build/
    在build目录下会看到新生成的wine软件包,安装即可。然后在crossover中会看到这个容器,运行里面的软件即可


    原文地址:
    回复

    使用道具 举报

  • TA的每日心情
    开心
    2016-10-18 08:56
  • 签到天数: 4 天

    [LV.2]偶尔看看I

    发表于 2016-10-14 11:16:20 | 显示全部楼层
    多谢大神分享;不过不敢尝试。刚装好国际版2012,才能使用。有谁做下小白  _  __ (_)/   \<'_, ____)~~~~~~~     ^^   ^^
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    发表于 2016-10-30 20:38:27 | 显示全部楼层
    0% [正在连接 archive.ubuntukylin.com (61.144.43.73)]
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    发表于 2016-10-30 20:40:12 | 显示全部楼层
    fax92888 发表于 2016-10-30 20:38
    0% [正在连接 archive.ubuntukylin.com (61.144.43.73)]

    打命令sudo apt-get update

    命中:1 http://cn.archive.ubuntu.com/ubuntu yakkety InRelease
    获取:2 http://cn.archive.ubuntu.com/ubuntu yakkety-updates InRelease [94.5 kB]                                                                           
    命中:3 http://cn.archive.ubuntu.com/ubuntu yakkety-backports InRelease                                                                                       
    获取:4 http://cn.archive.ubuntu.com/ubuntu yakkety-updates/main amd64 Packages [51.1 kB]                                             
    获取:5 http://cn.archive.ubuntu.com/ubuntu yakkety-updates/main i386 Packages [50.4 kB]                                             
    获取:6 http://cn.archive.ubuntu.com/ubuntu yakkety-updates/universe i386 Packages [24.5 kB]                                          
    获取:7 http://cn.archive.ubuntu.com/ubuntu yakkety-updates/universe amd64 Packages [24.5 kB]                                         
    获取:8 http://security.ubuntu.com/ubuntu yakkety-security InRelease [93.3 kB]                                                                                
    命中:9 http://archive.canonical.com/ubuntu yakkety InRelease                                                                     
    0% [正在连接 archive.ubuntukylin.com (61.144.43.73)]       卡住了!!!
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    发表于 2016-10-30 20:45:33 | 显示全部楼层
    好像现在可以了 密钥有显示!附加传送门 Ubuntu下如何使用命令行(apt-get)更新软件_百度经验 http://jingyan.baidu.com/article/4853e1e53204251909f7260f.html  不知道有没用^_^
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    奋斗
    2017-7-17 09:20
  • 签到天数: 27 天

    [LV.4]偶尔看看III

     楼主| 发表于 2016-12-9 09:23:14 | 显示全部楼层
    zzgzst3 发表于 2016-10-14 11:16
    多谢大神分享;不过不敢尝试。刚装好国际版2012,才能使用。有谁做下小白  _  __ (_)/   \

    放心装吧。没问题的。我装过好多次了。
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    奋斗
    2017-7-17 09:20
  • 签到天数: 27 天

    [LV.4]偶尔看看III

     楼主| 发表于 2016-12-9 09:24:17 | 显示全部楼层
    fax92888 发表于 2016-10-30 20:40
    打命令sudo apt-get update

    命中:1 http://cn.archive.ubuntu.com/ubuntu yakkety InRelease

    这是你搜狗输入法的问题吧。你从/etc/apt/sourcelist.d/ 里把搜狗的备份一下,然后删掉重新update就好了。
    回复 支持 反对

    使用道具 举报

    您需要登录后才可以回帖 登录 | 立即注册

    本版积分规则

    小黑屋|手机版|Archiver|Ubuntu Kylin    

    GMT+8, 2019-5-26 18:29 , Processed in 0.028451 second(s), 10 queries , File On.

    Copyright ©2013-2019 Ubuntu Kylin. All Rights Reserved .

    ICP No. 15002470-2 Tianjin

    快速回复 返回顶部 返回列表