设为首页收藏本站返回主页

Ubuntu Kylin技术论坛

 找回密码
 立即注册
搜索
查看: 1432|回复: 2

Windows与ubuntu时间不一致修改

[复制链接]
发表于 2016-10-1 16:09:28 | 显示全部楼层 |阅读模式
如果安装了 Windows 和 Linux(比如 Ubuntu)双系统,而且两个系统的时间都和互联网同步,有时会出现两个系统的时间不一致的情况(笔者遇到的情况是 Ubuntu 快 8 个小时)。本经验简单介绍一下出现这种情况如何调整。
工具/原料
安装了 Windows 10 / Ubuntu 16.04 双系统的电脑。
方法/步骤
因为双系统中 Windows 的时间与互联网同步,而且还想继续保持同步(毕竟这样时间准确),也没发现有可调整的项目可用,那就从 Ubuntu 这边调整。
进入 Ubuntu 桌面,按下 Ctrl + Alt + t 调出终端,键入以下命令:
sudo gedit /etc/default/rcS
意思是调用文本编辑器,编辑 /etc/default/ 文件夹下 rcS 这个文件的内容。
在打开的 gedit 文本编辑器窗口中,是上述 /etc/default/ 文件夹下 rcS 这个文件的内容。将光标定位到文档的末尾,加入下面这一行:
UTC=no
意思是系统时间不与 UTC (全球统一时间)同步。
保存文件、退出 gedit 编辑器、回到终端,继续键入以下命令:
sudo apt-get install ntpdate
意思是安装 ntpdate 这个命令。此命令用于调整系统时间。
然后运行命令:
sudo ntpdate ntp.sjtu.edu.cn
意思是与上海交大时间服务器同步(此地址由百度得来)。命令反馈:
9 Apr 17:25:40 ntpdate[3093]: adjust time server 202点120点2点100 offset 0.006167 sec
很快,Ubuntu 桌面上显示的系统时间成为上述命令返回的时间,与手机时间核对,正确。
注意这里的地址纯粹是命令返回的内容,为了防止被认为是违规,因此用了“点”字代替英文里的句点。
进入 Ubuntu 的时间设置界面,发现系统时间继续与互联网保持一致。
file:////tmp/wps-miao/ksohtml/wpseB5JpE.png
重新启动到 Windows 10,发现 Windows 这边的时间又慢了 8 小时。没办法,还是从互联网时间同步上想办法。进入控制面板,打开 Internet 时间设置,立即同步,Windows 的系统时间也正常了。

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
回复

使用道具 举报

发表于 2017-1-22 22:50:35 | 显示全部楼层
结果,,,还是都重新手动开启了一次网络同步时间,才能解决啊
回复 支持 反对

使用道具 举报

发表于 2017-9-13 13:57:38 | 显示全部楼层
你的方法太复杂了。让widows使用utc时间就可以了:

https://baike.1688.com/doc/view-d29558444.html

Windows Registry Editor Version 5.00 [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation]    "RealTimeIsUniversal"=dword:00000001以上内容存为.Reg文件,导入,或者手动修改即可让Windows使用UTC时间。这个方法适合于Linux/Windows双系统的用户,普通的Windows用户就不要折腾了,没这个必要。
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

小黑屋|手机版|Archiver|Ubuntu Kylin    

GMT+8, 2017-11-23 17:34 , Processed in 0.016524 second(s), 7 queries , File On.

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表