设为首页收藏本站返回主页

Ubuntu Kylin技术论坛

 找回密码
 立即注册
搜索
查看: 1325|回复: 6

启动终端一个有趣的动画

[复制链接]
发表于 2016-12-9 15:26:36 | 显示全部楼层 |阅读模式






动画GIF图片由于无法上传只好截图
#安装依赖
  1. sudo apt-get install libx32ncurses5-dev libx32ncursesw5-dev
复制代码
#现在克隆库:
  1. sudo apt-get install git
  2. git clone https://github.com/bartobri/no-more-secrets.git
  3. cd ./no-more-secrets
复制代码
#现在我们将编译源代码安装
  1. make
  2. sudo make install
复制代码


两个使用方式其余自己摸索玩
  1. ls -l | nms

  2. sneakers
复制代码
卸载到你安装的源码包
  1. sudo make uninstall
复制代码





























本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
回复

使用道具 举报

发表于 2016-12-9 16:36:59 | 显示全部楼层
还有跑火车,sl.
回复 支持 反对

使用道具 举报

发表于 2017-1-20 03:20:01 | 显示全部楼层
楼主 第一个语句就安装不了 怎么解

“The following packages have unmet dependencies:
libx32ncurses5-dev : Depends: libx32tinfo5 (= 6.0+20160213-1ubuntu1) but it is not going to be installed
                      Depends: libx32ncurses5 (= 6.0+20160213-1ubuntu1) but it is not going to be installed
                      Depends: libx32tinfo-dev (= 6.0+20160213-1ubuntu1) but it is not going to be installed
                      Depends: libc6-dev-x32 but it is not going to be installed
libx32ncursesw5-dev : Depends: libx32tinfo5 (= 6.0+20160213-1ubuntu1) but it is not going to be installed
                       Depends: libx32ncursesw5 (= 6.0+20160213-1ubuntu1) but it is not going to be installed
                       Depends: libx32tinfo-dev (= 6.0+20160213-1ubuntu1) but it is not going to be installed
                       Depends: libc6-dev-x32 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.”
回复 支持 反对

使用道具 举报

 楼主| 发表于 2017-1-20 12:06:36 | 显示全部楼层
韩可奇 发表于 2017-1-20 03:20
楼主 第一个语句就安装不了 怎么解

“The following packages have unmet dependencies:

自己去安装好依赖关系的软件包你的终端有提示
libx32ncurses5-dev
libx32ncursesw5-dev
libx32tinfo5
libx32ncursesw5
libx32tinfo-dev
libc6-dev-x32
回复 支持 反对

使用道具 举报

发表于 2017-1-27 01:31:47 | 显示全部楼层
笨鸟弟弟 发表于 2017-1-20 12:06
自己去安装好依赖关系的软件包你的终端有提示
libx32ncurses5-dev
libx32ncursesw5-dev

谢谢解答, 可是我安装还是缺文件, 只是想弄明白咋回事
“libc6-dev-x32 : Depends: libc6-x32 (= 2.23-0ubuntu3) but it is not going to be installed
                 Depends: libc6-dev-i386 (= 2.23-0ubuntu3) but it is not going to be installed
                 Depends: libc6-dev (= 2.23-0ubuntu3) but 2.23-0ubuntu5 is to be installed
E: Unable to correct problems, you have held broken packages.“

”libx32ncursesw5 : Depends: libx32tinfo5 (= 6.0+20160213-1ubuntu1) but it is not going to be installed
                   Depends: libc6-x32 (>= 2.16) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.“ 诸如此类, 何解?
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

小黑屋|手机版|Archiver|Ubuntu Kylin    

GMT+8, 2017-11-25 00:52 , Processed in 0.034610 second(s), 8 queries , File On.

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表