设为首页收藏本站返回主页

Ubuntu Kylin技术论坛

 找回密码
 立即注册
搜索
查看: 397|回复: 7

升级16.10无法上网,设备未托管

[复制链接]

该用户从未签到

参加活动: 0

组织活动: 0

发表于 2017-4-14 14:32:38 | 显示全部楼层 |阅读模式
虚拟机使用NAT,原来上网都是正常的。系统升级到16.10后,设备显示未托管。按照网上的方法,在 /etc/NetworkManager/NetworkManager.conf 里修改为此设置 managed=true 还是不行。
求助,急!!!
回复

使用道具 举报

  • TA的每日心情
    郁闷
    3 天前
  • 签到天数: 700 天

    [LV.9]以坛为家II

    参加活动: 0

    组织活动: 0

    发表于 2017-4-14 14:47:01 | 显示全部楼层
    额,试试,打开终端:
    ifconfig查看下网卡信息

    sudo ifconfig xxx up   #开启网卡,xxx为上诉命令里查到的网卡代号

    sudo dhclient xxx  #更新IP地址

    sudo ifconfig xxx
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    参加活动: 0

    组织活动: 0

     楼主| 发表于 2017-4-14 14:49:52 | 显示全部楼层
    handsome_feng 发表于 2017-4-14 14:47
    额,试试,打开终端:
    ifconfig查看下网卡信息

    lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
            inet 127.0.0.1  netmask 255.0.0.0
            inet6 ::1  prefixlen 128  scopeid 0x10<host>
            loop  txqueuelen 1  (本地环回)
            RX packets 29540  bytes 1772400 (1.7 MB)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 29540  bytes 1772400 (1.7 MB)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    哪个是名字???
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    郁闷
    3 天前
  • 签到天数: 700 天

    [LV.9]以坛为家II

    参加活动: 0

    组织活动: 0

    发表于 2017-4-14 14:56:24 | 显示全部楼层
    tiancaiztc 发表于 2017-4-14 14:49
    lo: flags=73  mtu 65536
            inet 127.0.0.1  netmask 255.0.0.0
            inet6 ::1  prefixlen 1 ...

    额,用ifconfig -a, 和“lo"一样地方的位置就是
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    参加活动: 0

    组织活动: 0

     楼主| 发表于 2017-4-14 14:59:07 | 显示全部楼层
    handsome_feng 发表于 2017-4-14 14:56
    额,用ifconfig -a, 和“lo"一样地方的位置就是

    可以上网了,但是右上角的网络里,以太网还是显示未托管...
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    郁闷
    3 天前
  • 签到天数: 700 天

    [LV.9]以坛为家II

    参加活动: 0

    组织活动: 0

    发表于 2017-4-14 15:04:26 | 显示全部楼层
    tiancaiztc 发表于 2017-4-14 14:59
    可以上网了,但是右上角的网络里,以太网还是显示未托管...

    恩,这是临时解决方案,可能每次重启都要这样操作一遍,可能是升级过程中破换了哪个服务或者配置,最好是备份下文件,重新装个系统,或者继续升级到17.04试试?话说你是具体哪个版本升级上来的?
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    参加活动: 0

    组织活动: 0

     楼主| 发表于 2017-4-14 15:09:19 | 显示全部楼层
    handsome_feng 发表于 2017-4-14 15:04
    恩,这是临时解决方案,可能每次重启都要这样操作一遍,可能是升级过程中破换了哪个服务或者配置,最好是 ...

    16.04升上来的。嗯,我现在就在升17.04试试看
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    参加活动: 0

    组织活动: 0

    发表于 2017-4-15 02:10:53 | 显示全部楼层
    终端sudo nautilus  以root形式打开文件管理器  etc/network/interfaces这个文件。打开之后在最后的iface前面加一个#,注销重新登录就好了,希望帮到你
    回复 支持 反对

    使用道具 举报

    您需要登录后才可以回帖 登录 | 立即注册

    本版积分规则

    Archiver|手机版|小黑屋|Ubuntu Kylin    

    GMT+8, 2017-6-25 03:07 , Processed in 0.041201 second(s), 25 queries .

    Powered by Discuz! X3.2

    © 2001-2013 Comsenz Inc.

    快速回复 返回顶部 返回列表