Ubuntu Kylin技术论坛

 找回密码
楼主: waxiyibian

搞事情:linux下安装迅雷和qq。(迅雷接近完美,qq能记住密码,不能视频)

  [复制链接]
  • TA的每日心情
    开心
    2018-7-24 13:27
  • 签到天数: 36 天

    [LV.5]常住居民I

     楼主| 发表于 2017-5-19 07:46:14 | 显示全部楼层
    yuhongxin9339 发表于 2017-5-18 12:55
    谢谢你了,电脑上就一个系统,百度云客户端有liux版的?

    百度云官方没有出linux版的,但是有很多替代方案,比如github上Yufeikang今年更新的bcloud,或者是命令行百度云客户端baidupcs,以及正在开发的BNetDisk。或者也可以在crossover的QQ容器中直接安装最新版百度云,wine的话暂时没有很好的解决方案,单纯想提高百度云的下载速度的话也可以使用油猴插件,或者复制链接地址用uget或者迅雷来下载。总之解决方法非常多,像你说的提取错误的这个问题其实很好解决。
    回复 支持 1 反对 0

    使用道具 举报

  • TA的每日心情
    开心
    2019-1-1 19:45
  • 签到天数: 110 天

    [LV.6]常住居民II

    发表于 2017-5-19 15:57:05 | 显示全部楼层
    谢谢你,技术高,人也好,时间了再折腾下,成了告诉你
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    开心
    2019-1-1 19:45
  • 签到天数: 110 天

    [LV.6]常住居民II

    发表于 2017-5-19 15:59:03 | 显示全部楼层
    waxiyibian 发表于 2017-5-19 07:46
    百度云官方没有出linux版的,但是有很多替代方案,比如github上Yufeikang今年更新的bcloud,或者是命令行 ...

    谢谢你,技术高,人也好,时间了再折腾下,成了告诉你
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    奋斗
    2017-5-24 10:20
  • 签到天数: 2 天

    [LV.1]初来乍到

    发表于 2017-5-20 18:10:49 | 显示全部楼层
    (正在读取数据库 ... 系统当前共安装有 240802 个文件和目录。)
    正在卸载 libreadline7:i386 (7.0-1) ...
    (正在读取数据库 ... 系统当前共安装有 240798 个文件和目录。)
    正准备解包 .../libpng16-16_1.6.28-1_i386.deb  ...
    正在将 libpng16-16:i386 (1.6.28-1) 解包到 (1.6.26-1) 上 ...
    dpkg: 处理归档 /var/cache/apt/archives/libpng16-16_1.6.28-1_i386.deb (--unpack)时出错:
    尝试覆盖共享的 '/usr/share/doc/libpng16-16/ANNOUNCE', 它与软件包 libpng16-16:i386 中的其他实例不同
    dpkg-deb: 错误: 子进程 粘贴 被信号(断开的管道) 终止了
    在处理时有错误发生:
    /var/cache/apt/archives/libpng16-16_1.6.28-1_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    奋斗
    2017-5-24 10:20
  • 签到天数: 2 天

    [LV.1]初来乍到

    发表于 2017-5-20 18:12:14 | 显示全部楼层
    ,安装出错,Ubuntu Kylin 17.04 64位

    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    开心
    2018-7-24 13:27
  • 签到天数: 36 天

    [LV.5]常住居民I

     楼主| 发表于 2017-5-20 18:39:12 | 显示全部楼层
    本帖最后由 waxiyibian 于 2017-5-20 18:43 编辑
    wantfly1981 发表于 2017-5-20 18:12
    ,安装出错,Ubuntu Kylin 17.04 64位

    可以尝试如下操作:
    sudo --force-depends -r libpng16-16:i386
    sudo apt-get install libpng16-16:i386
    sudo apt-get install -f
    然后把安装包里面deepin-wine-helper-d里的libpng16-16_1.6.26-1_i386.deb删掉,重新执行
    sudo bash install.sh
    问题已经记录,下次有时间我再修改一下教程。
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    奋斗
    2017-5-24 10:20
  • 签到天数: 2 天

    [LV.1]初来乍到

    发表于 2017-5-20 20:40:17 | 显示全部楼层
    正在读取软件包列表... 完成
    正在分析软件包的依赖关系树      
    正在读取状态信息... 完成      
    lib32ncurses5 已经是最新版 (6.0+20160625-1ubuntu1)。
    lib32z1 已经是最新版 (1:1.2.11.dfsg-0ubuntu1)。
    libp11-kit-gnome-keyring:i386 已经是最新版 (3.20.0-3ubuntu2)。
    libp11-kit0:i386 已经是最新版 (0.23.3-5)。
    libxt6:i386 已经是最新版 (1:1.1.5-1)。
    ocl-icd-libopencl1:i386 已经是最新版 (2.2.11-1ubuntu1)。
    odbcinst:i386 已经是最新版 (2.3.4-1)。
    odbcinst1debian2:i386 已经是最新版 (2.3.4-1)。
    p11-kit-modules:i386 已经是最新版 (0.23.3-5)。
    p7zip 已经是最新版 (16.02+dfsg-2)。
    p7zip-full 已经是最新版 (16.02+dfsg-2)。
    您也许需要运行“apt --fix-broken install”来修正上面的错误。
    下列软件包有未满足的依赖关系:
    libfreetype6:i386 : 依赖: libpng16-16:i386 (>= 1.6.2-1) 但是它将不会被安装
    libgd3:i386 : 依赖: libpng16-16:i386 (>= 1.6.2-1) 但是它将不会被安装
    unixodbc : 冲突: unixodbc:i386
    unixodbc:i386 : 依赖: libreadline7:i386 (>= 6.0) 但是它将不会被安装
                     冲突: unixodbc
    E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt --fix-broken install”(也可以指定一个解决办法)。
    正在选中未选择的软件包 libgif4:i386。
    (正在读取数据库 ... 系统当前共安装有 239034 个文件和目录。)
    正准备解包 .../libgif4_4.1.6-11_i386.deb  ...
    正在解包 libgif4:i386 (4.1.6-11) ...
    正在选中未选择的软件包 libgnutls26:i386。
    正准备解包 .../libgnutls26_2.12.23-18_i386.deb  ...
    正在解包 libgnutls26:i386 (2.12.23-18) ...
    正在选中未选择的软件包 libgnutls-deb0-28:i386。
    正准备解包 .../libgnutls-deb0-28_3.3.20-1_i386.deb  ...
    正在解包 libgnutls-deb0-28:i386 (3.3.20-1) ...
    正在选中未选择的软件包 libgstreamer0.10-0:i386。
    正准备解包 .../libgstreamer0.10-0_0.10.36-1.5_i386.deb  ...
    正在解包 libgstreamer0.10-0:i386 (0.10.36-1.5) ...
    正在选中未选择的软件包 libgstreamer-plugins-base0.10-0:i386。
    正准备解包 .../libgstreamer-plugins-base0.10-0_0.10.36-2_i386.deb  ...
    正在解包 libgstreamer-plugins-base0.10-0:i386 (0.10.36-2) ...
    正在选中未选择的软件包 libreadline7:i386。
    正准备解包 .../libreadline7_7.0-1_i386.deb  ...
    正在反配置 libreadline7:amd64 (7.0-0ubuntu2) ...
    正在解包 libreadline7:i386 (7.0-1) ...
    正在设置 libgif4:i386 (4.1.6-11) ...
    正在设置 libgnutls26:i386 (2.12.23-18) ...
    正在设置 libgnutls-deb0-28:i386 (3.3.20-1) ...
    正在设置 libgstreamer0.10-0:i386 (0.10.36-1.5) ...
    正在设置 libgstreamer-plugins-base0.10-0:i386 (0.10.36-2) ...
    dpkg: 处理软件包 libreadline7:i386 (--install)时出错:
    现在尚不能配置软件包 libreadline7:i386 7.0-1,因为 libreadline7:amd64 处于一个不同的版本(7.0-0ubuntu2)
    dpkg: 处理软件包 libreadline7:amd64 (--install)时出错:
    现在尚不能配置软件包 libreadline7:amd64 7.0-0ubuntu2,因为 libreadline7:i386 处于一个不同的版本(7.0-1)
    正在处理用于 libc-bin (2.24-9ubuntu2) 的触发器 ...
    在处理时有错误发生:
    libreadline7:i386
    libreadline7:amd64
    正在选中未选择的软件包 deepin-fonts-wine。
    (正在读取数据库 ... 系统当前共安装有 239237 个文件和目录。)
    正准备解包 .../deepin-fonts-wine_1.9-26_all.deb  ...
    正在解包 deepin-fonts-wine (1.9-26) ...
    正在选中未选择的软件包 deepin-libwine:i386。
    正准备解包 .../deepin-libwine_1.9-26_i386.deb  ...
    正在解包 deepin-libwine:i386 (1.9-26) ...
    正在选中未选择的软件包 deepin-wine32:i386。
    正准备解包 .../deepin-wine32_1.9-26_i386.deb  ...
    正在解包 deepin-wine32:i386 (1.9-26) ...
    正准备解包 .../udis86_1.72-2_i386.deb  ...
    正在将 udis86:i386 (1.72-2) 解包到 (1.72-2) 上 ...
    正在设置 deepin-fonts-wine (1.9-26) ...
    正在设置 deepin-libwine:i386 (1.9-26) ...
    正在设置 deepin-wine32:i386 (1.9-26) ...
    正在设置 udis86:i386 (1.72-2) ...
    正在处理用于 libc-bin (2.24-9ubuntu2) 的触发器 ...
    正在选中未选择的软件包 deepin-wine。
    (正在读取数据库 ... 系统当前共安装有 240721 个文件和目录。)
    正准备解包 .../deepin-wine_1.9-26_all.deb  ...
    正在解包 deepin-wine (1.9-26) ...
    正在选中未选择的软件包 deepin-wine32-preloader:i386。
    正准备解包 .../deepin-wine32-preloader_1.9-26_i386.deb  ...
    正在解包 deepin-wine32-preloader:i386 (1.9-26) ...
    正在选中未选择的软件包 deepin-wine-helper:i386。
    正准备解包 .../deepin-wine-helper_1.0deepin17_i386.deb  ...
    正在解包 deepin-wine-helper:i386 (1.0deepin17) ...
    正在选中未选择的软件包 deepin-wine-uninstaller:i386。
    正准备解包 .../deepin-wine-uninstaller_0.1deepin2_i386.deb  ...
    正在解包 deepin-wine-uninstaller:i386 (0.1deepin2) ...
    正在设置 deepin-wine (1.9-26) ...
    正在设置 deepin-wine32-preloader:i386 (1.9-26) ...
    dpkg: 依赖关系问题使得 deepin-wine-helper:i386 的配置工作不能继续:
    deepin-wine-helper:i386 依赖于 libgphoto2-6;然而:
      软件包 libgphoto2-6:i386 尚未配置。
    deepin-wine-helper:i386 依赖于 libsane;然而:
      软件包 libsane:i386 尚未配置。

    dpkg: 处理软件包 deepin-wine-helper:i386 (--install)时出错:
    依赖关系问题 - 仍未被配置
    正在设置 deepin-wine-uninstaller:i386 (0.1deepin2) ...
    正在处理用于 man-db (2.7.6.1-2) 的触发器 ...
    在处理时有错误发生:
    deepin-wine-helper:i386
    正在选中未选择的软件包 deepin.com.qq.im:i386。
    (正在读取数据库 ... 系统当前共安装有 240769 个文件和目录。)
    正准备解包 deepin.com.qq.im_8.9.19983deepin16_i386.deb  ...
    正在解包 deepin.com.qq.im:i386 (8.9.19983deepin16) ...
    dpkg: 依赖关系问题使得 deepin.com.qq.im:i386 的配置工作不能继续:
    deepin.com.qq.im:i386 依赖于 deepin-wine-helper;然而:
      软件包 deepin-wine-helper:i386 尚未配置。

    dpkg: 处理软件包 deepin.com.qq.im:i386 (--install)时出错:
    依赖关系问题 - 仍未被配置
    在处理时有错误发生:
    deepin.com.qq.im:i386
    正在选中未选择的软件包 deepin.com.thunderspeed:i386。
    (正在读取数据库 ... 系统当前共安装有 240789 个文件和目录。)
    正准备解包 deepin.com.thunderspeed_7.10.35.366deepin15_i386.deb  ...
    正在解包 deepin.com.thunderspeed:i386 (7.10.35.366deepin15) ...
    dpkg: 依赖关系问题使得 deepin.com.thunderspeed:i386 的配置工作不能继续:
    deepin.com.thunderspeed:i386 依赖于 deepin-wine-helper;然而:
      软件包 deepin-wine-helper:i386 尚未配置。

    dpkg: 处理软件包 deepin.com.thunderspeed:i386 (--install)时出错:
    依赖关系问题 - 仍未被配置
    在处理时有错误发生:
    deepin.com.thunderspeed:i386
    正在读取软件包列表... 完成
    正在分析软件包的依赖关系树      
    正在读取状态信息... 完成      
    正在修复依赖关系... 完成
    下列软件包是自动安装的并且现在不需要了:
      libodbc1:i386
    使用'sudo apt autoremove'来卸载它(它们)。
    将会同时安装下列软件:
      libpng16-16:i386
    下列软件包将被【卸载】:
      libreadline7:i386
    下列【新】软件包将被安装:
      libpng16-16:i386
    升级了 0 个软件包,新安装了 1 个软件包,要卸载 1 个软件包,有 24 个软件包未被升级。
    有 9 个软件包没有被完全安装或卸载。
    需要下载 0 B/181 kB 的归档。
    解压缩后将会空出 59.4 kB 的空间。
    您希望继续执行吗? [Y/n] y
    (正在读取数据库 ... 系统当前共安装有 240799 个文件和目录。)
    正在卸载 libreadline7:i386 (7.0-1) ...
    正在选中未选择的软件包 libpng16-16:i386。
    (正在读取数据库 ... 系统当前共安装有 240795 个文件和目录。)
    正准备解包 .../libpng16-16_1.6.28-1_i386.deb  ...
    正在解包 libpng16-16:i386 (1.6.28-1) ...
    dpkg: 处理归档 /var/cache/apt/archives/libpng16-16_1.6.28-1_i386.deb (--unpack)时出错:
    尝试覆盖共享的 '/usr/share/doc/libpng16-16/ANNOUNCE', 它与软件包 libpng16-16:i386 中的其他实例不同
    dpkg-deb: 错误: 子进程 粘贴 被信号(断开的管道) 终止了
    在处理时有错误发生:
    /var/cache/apt/archives/libpng16-16_1.6.28-1_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    奋斗
    2017-5-24 10:20
  • 签到天数: 2 天

    [LV.1]初来乍到

    发表于 2017-5-20 20:41:38 | 显示全部楼层
    还是有问题
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    奋斗
    2017-5-24 10:20
  • 签到天数: 2 天

    [LV.1]初来乍到

    发表于 2017-5-20 20:44:59 | 显示全部楼层
    运行 sudo apt-get install -f
    下列软件包是自动安装的并且现在不需要了:
      libodbc1:i386
    使用'sudo apt autoremove'来卸载它(它们)。
    将会同时安装下列软件:
      libpng16-16:i386
    下列【新】软件包将被安装:
      libpng16-16:i386
    升级了 0 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 24 个软件包未被升级。
    有 8 个软件包没有被完全安装或卸载。
    需要下载 0 B/181 kB 的归档。
    解压缩后会消耗 353 kB 的额外空间。
    您希望继续执行吗? [Y/n] y
    正在选中未选择的软件包 libpng16-16:i386。
    (正在读取数据库 ... 系统当前共安装有 240795 个文件和目录。)
    正准备解包 .../libpng16-16_1.6.28-1_i386.deb  ...
    正在解包 libpng16-16:i386 (1.6.28-1) ...
    dpkg: 处理归档 /var/cache/apt/archives/libpng16-16_1.6.28-1_i386.deb (--unpack)时出错:
    尝试覆盖共享的 '/usr/share/doc/libpng16-16/ANNOUNCE', 它与软件包 libpng16-16:i386 中的其他实例不同
    dpkg-deb: 错误: 子进程 粘贴 被信号(断开的管道) 终止了
    在处理时有错误发生:
    /var/cache/apt/archives/libpng16-16_1.6.28-1_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    开心
    2018-7-24 13:27
  • 签到天数: 36 天

    [LV.5]常住居民I

     楼主| 发表于 2017-5-20 22:02:52 | 显示全部楼层
    wantfly1981 发表于 2017-5-20 20:44
    运行 sudo apt-get install -f
    下列软件包是自动安装的并且现在不需要了:
      libodbc1:i386

    大概明白了,你打开终端,再执行:
    sudo rm /usr/share/doc/libpng16-16/ANNOUNCE
    sudo apt-get remove libobc1:i386
    sudo dpkg --force-depends -r libreadline7:i386
    sudo apt-get install libpng16-16 libreadline7 libreadline7:i386
    应该就安装完成了,直接在开始菜单中搜索QQ和迅雷就可以看到了,如果没有看到的话可以先注销再登录。不过为了保险,建议你把deepin-wine-helper-d里面的libreadline7_7.0-1_i386.deb也删除了,然后把install.sh和remove.sh替换成这两个,免得下次安装或者卸载出现问题。

    本帖子中包含更多资源

    您需要 登录 才可以下载或查看,没有帐号?立即注册

    x
    回复 支持 反对

    使用道具 举报

    您需要登录后才可以回帖 登录 | 立即注册

    本版积分规则

    小黑屋|手机版|Archiver|Ubuntu Kylin    

    GMT+8, 2019-1-18 22:49 , Processed in 0.019461 second(s), 8 queries , File On.

    Copyright ©2013-2018 Ubuntu Kylin. All Rights Reserved .

    ICP No. 15002470-2 Tianjin

    快速回复 返回顶部 返回列表