设为首页收藏本站返回官网

Ubuntu Kylin技术论坛

 找回密码
 立即注册
搜索
查看: 2362|回复: 5

UbuntuKylin17.10 64位折腾网易云音乐并完美运行附安装包

[复制链接]
  • TA的每日心情
    难过
    2017-10-21 07:37
  • 签到天数: 54 天

    [LV.5]常住居民I

    发表于 2017-10-18 22:27:02 | 显示全部楼层 |阅读模式
    本帖最后由 sanant 于 2017-10-21 22:06 编辑

    来源于sanant的个人网站,先放个效果图


    2017.10.21 如果你是UK17.10正式版新系统,安装网易云音乐启动后,如果出现以下错误

    是需要VLC PLUGIN的支持
    sudo apt-get install vlc-plugin-base


    我的系统是UK17.10,目前支持的内核和系统补丁应该都是最新的。

    在17.10中,从官网http://music.163.com/#/download下载安装网易云音乐会出现无法运行的情况

    在程序栏里运行没反应,在终端内运行 netease-cloud-music %U ,要么不提示信息要么显示如下错误

    网上有网友说将命令更换为 netease-cloud-music --no-sandbox %U 执行
    会提示如下错误
    [1018/220422:ERROR:browser_main_loop.cc(203)] Running without the SUID sandbox! See https://code.google.com/p/chromi ... DSandboxDevelopment for more information on developing with the sandbox on.
    网易云音乐可能能打开,但打开后发现歌词无法显示。

    其实,网易云音乐官方提供的是1.0.0-2版本(33.7MB),最新的版本其实1.0.1版本(50.2MB)

    在安装最新版的时候发现缺少依赖:libfontconfig1(≥2.12),你会崩溃的发现就算是系统最新也才是2.11.92,就算是在网上下载了大于2.12的版本也因为破坏了系统装不上

    所以自己动手重新编译了一下,安装可以从程序栏完美运行,并且不用--no-sandbox,最重要的完美支持歌词

    附上打包后的地址,有需要的请自行安装
    链接: https://pan.baidu.com/s/1pLOGwLt 密码: g9rv




    本帖子中包含更多资源

    您需要 登录 才可以下载或查看,没有帐号?立即注册

    x

    评分

    参与人数 1麒麟币 +15 收起 理由
    handsome_feng + 15 赞一个!

    查看全部评分

    回复

    使用道具 举报

  • TA的每日心情
    郁闷
    2017-10-20 13:07
  • 签到天数: 2 天

    [LV.1]初来乍到

    发表于 2017-10-20 11:12:24 | 显示全部楼层
    无法安装是为什么?
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    难过
    2017-10-21 07:37
  • 签到天数: 54 天

    [LV.5]常住居民I

     楼主| 发表于 2017-10-20 12:27:55 | 显示全部楼层
    本帖最后由 sanant 于 2017-10-20 15:01 编辑
    1952288355 发表于 2017-10-20 11:12
    无法安装是为什么?

    提示什么?
    依赖库安装完了吗?建议用gdebi安装,它会自动安装依赖库。
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    慵懒
    2017-11-13 08:08
  • 签到天数: 1 天

    [LV.1]初来乍到

    发表于 2017-11-13 14:02:56 | 显示全部楼层
    还是不行啊,还是有错误,下载的修改包而且用edebi装得

    本帖子中包含更多资源

    您需要 登录 才可以下载或查看,没有帐号?立即注册

    x
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    难过
    2017-10-21 07:37
  • 签到天数: 54 天

    [LV.5]常住居民I

     楼主| 发表于 2017-11-13 22:04:33 | 显示全部楼层
    薄荷 发表于 2017-11-13 14:02
    还是不行啊,还是有错误,下载的修改包而且用edebi装得

    帖子里我写的有啊,第2张图下面。
    是需要VLC PLUGIN的支持
    sudo apt-get install vlc-plugin-base
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    难过
    2017-10-21 07:37
  • 签到天数: 54 天

    [LV.5]常住居民I

     楼主| 发表于 2017-11-13 22:40:15 | 显示全部楼层
    已测试,18.04正常。
    回复 支持 反对

    使用道具 举报

    您需要登录后才可以回帖 登录 | 立即注册

    本版积分规则

    小黑屋|手机版|Archiver|Ubuntu Kylin    

    GMT+8, 2018-1-24 15:11 , Processed in 0.191071 second(s), 11 queries , File On.

    Powered by Discuz! X3.3

    © 2013-2018 Comsenz Inc.

    快速回复 返回顶部 返回列表