设为首页收藏本站返回官网

Ubuntu Kylin技术论坛

 找回密码
 立即注册
搜索
查看: 356|回复: 2

让Chromium的Flash插件正确运行

[复制链接]
  • TA的每日心情
    奋斗
    2017-10-27 10:13
  • 签到天数: 2 天

    [LV.1]初来乍到

    发表于 2017-10-25 09:58:48 | 显示全部楼层 |阅读模式
    本帖最后由 go2study 于 2017-10-26 14:42 编辑

    让Chromium的Flash插件正确运行
    我不算是技术控,但是个Linux爱好者,Ubuntu(或者Ubuntu Kylin)上最好的两个浏览器莫过于Firefox和Chromium,因Firefox配置了代理常用来翻墙,所以Chromium就成了我日常使用的浏览器,但是,困扰很多人的一个问题是明明用系统自带的软件和更新等程序安装了Flash插件,但是很多网页上的Flash内容还是无法播放,频繁提示让安装Flash插件,到了Adobe的网站上,下载安装依然问题存在,什么原因我就不细分析了,直接上最实用的内容:

    我的这个配置在Ubuntu Kylin 17.10 + Chromium 62.0.3202.62 上经验证完美运行各类网页的Flash。

    帖子基本上是小白帖,按步骤执行即可(我假设你很喜欢Linux,但是又没那么极客):

    第1步:删除Chromium当前的Flash插件(这一步很关键,不管有没有安装过Flash插件,都建议做个确认,如果安装了,一定要删除之前的版本)
    $  cd /usr/lib/chromium-browser/plugins/
    $  ls
    文件列表出现后,看看有没有任何以 flashplayer.so结尾的文件,如果有,请执行如下步骤删除,如果没有,说明未安装Flash插件,可以跳到第2步
    $  sudo rm *flashplayer.so  (注意,执行此命令,需要你在/usr/lib/chromium-browser/plugins/ 目录下,如果没有,请进入该目录)

    第2步:下载最新的Chromium Flash插件


    2.1  用浏览器打开此页面:
    http://labs.adobe.com/downloads/flashplayer.html

    2.2  页面打开后,会看到如下的页面:

    Flash Player 27 Beta Installers
    Universal 32-bit and 64-bit installers
    Windows
    Download Flash Player for Internet Explorer - ActiveXDownload Flash Player for Internet Explorer - ActiveX
    Download Flash Player for Firefox and Netscape Plug-In compatible applications – NPAPI Download Flash Player for Firefox and Netscape Plug-In compatible applications – NPAPI
    Download Flash Player for Opera and Chromium based applications – PPAPIDownload Flash Player for Opera and Chromium based applications – PPAPI
    Mac
    Download Flash Player for Safari, Firefox and Netscape Plug-In compatible applications – NPAPIDownload Flash Player for Safari, Firefox and Netscape Plug-In compatible applications – NPAPI
    Download Flash Player for Opera and Chromium based applications – PPAPIDownload Flash Player for Opera and Chromium based applications – PPAPI
    Linux
    Download Flash Player for Safari, Firefox and Netscape Plug-In compatible applications – NPAPIDownload Flash Player for Firefox and Netscape Plug-In compatible applications – NPAPI (64-bit)
    Download Flash Player for Opera and Chromium based applications – PPAPIDownload Flash Player for Firefox and Netscape Plug-In compatible applications – NPAPI (32-bit)
    Download Flash Player for Safari, Firefox and Netscape Plug-In compatible applications – NPAPIDownload Flash Player for Opera and Chromium based applications - PPAPI (64-bit)
    Download Flash Player for Safari, Firefox and Netscape Plug-In compatible applications – NPAPIDownload Flash Player for Opera and Chromium based applications - PPAPI (32-bit)

    根据需要,下载一个适合你的系统的Chromium插件,我使用的是32-bit的Ubuntu Kylin,因此选择了最后一个(NPAPIDownload Flash Player for Opera and Chromium based applications - PPAPI (32-bit)

    如果你使用的系统为64-bit,请选择倒数第二个 (NPAPIDownload Flash Player for Opera and Chromium based applications - PPAPI (64-bit)


    第3步:解压插件并准备安装
    下载的文件应该是一个类似 flash_player_ppapi_linux.i386.tar.gz 的文件
    双击文件,将其解压至某个目录,例如,我的解压至 /home/xhu/download/flash     (注意,xhu是我的用户名)

    打开命令行终端,进入该目录:
    $   cd /home/xhu/download/flash

    目录下应该有如下的文件夹与文件:

    LGPL     文件夹(版权相关信息,对安装无影响,不用关注)
    libpepflashplayer.so   (这个就是我们需要的插件了)
    license.pdf      (版权相关信息,对安装无影响,不用关注)
    manifest.json  (这个文件中包含的一个信息等下对我们很有用)
    readme.txt  (说明文件)

    第4步:将Flash插件拷贝到Chromium的插件目录

    $   cd /home/xhu/download/flash
    $  sudo cp libpepflashplayer.so  /usr/lib/chromium-browser/plugins/

    到Chromium的插件目录做个确认
    $cd /usr/lib/chromium-browser/plugins/
    $ls

    此时,目录下应该可以看到libpepflashplayer.so文件了,好了,只差最后一步了


    第5步:配置Chromium使用刚刚的Flash插件

    5.1 首先,我们需要知道Flash插件的确切版本号
    进入刚刚Flash插件的解压目录
    $   cd /home/xhu/download/flash

    找到manifest.json文件,使用任何的文本便捷器打开,例如gedit
    $  gedit manifest.json     (如果你安装了gvim,没安装gedit,那就用这个命令: $ gvim manifest.json  )
    文件打开后,可以看到前几行有个类似  "version": "27.0.0.180" 的东西,就是这个了,记下该版本号,例如我下载的这个为:27.0.0.180

    5.2 修改Chromium的配置文件
    $ sudo gedit /etc/chromium-browser/default

    文件打开后会看到类似如下的内容:
    # Default settings for chromium-browser. This file is sourced by /bin/sh from
    # /usr/bin/chromium-browser
    # Options to pass to chromium-browser
    CHROMIUM_FLAGS=""


    好的,我们的任务就是填写CHROMIUM_FLAGS="" 引号中的内容,使其指向我们安装的插件,修改后的内容如下:
    # Default settings for chromium-browser. This file is sourced by /bin/sh from
    # /usr/bin/chromium-browser
    # Options to pass to chromium-browser
    CHROMIUM_FLAGS="--ppapi-flash-path=/usr/lib/chromium-browser/plugins/libpepflashplayer.so --ppapi-flash-version=27.0.0.180"


    怕出问题的可以把引号中的内容拷贝走,并将版本号替换为自己刚刚在5.1步骤中记下的版本号。

    至此,配置完毕,关闭并重启Chromium,开心地播放网页的Flash内容吧!
    以后记得,每次更新Flash插件时,照此文内容进行一次更新,修改Chromium的配置文件指向最新的Flash插件即可。


    受启发于此贴(这个帖子内容丰富,而且也比较技术,不过对于有些朋友可能过于复杂了),感谢原作者!有兴趣的朋友可以看看:
    https://www.ubuntukylin.com/ukylin/forum.php?mod=viewthread&tid=28044&highlight=flash


    回复

    使用道具 举报

  • TA的每日心情
    无聊
    2017-10-27 10:31
  • 签到天数: 19 天

    [LV.4]偶尔看看III

    发表于 2017-10-27 10:46:23 | 显示全部楼层
    不知道为什么chrome不会自动找到那个flash查件,非要手动指定
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    奋斗
    2017-10-27 10:13
  • 签到天数: 2 天

    [LV.1]初来乍到

     楼主| 发表于 2017-10-27 10:52:18 | 显示全部楼层
    kylin0061 发表于 2017-10-27 10:46
    不知道为什么chrome不会自动找到那个flash查件,非要手动指定

    这一步做了么?

    5.2 修改Chromium的配置文件
    $ sudo gedit /etc/chromium-browser/default

    文件打开后会看到类似如下的内容:
    # Default settings for chromium-browser. This file is sourced by /bin/sh from
    # /usr/bin/chromium-browser
    # Options to pass to chromium-browser
    CHROMIUM_FLAGS=""


    好的,我们的任务就是填写CHROMIUM_FLAGS="" 引号中的内容,使其指向我们安装的插件,修改后的内容如下:
    # Default settings for chromium-browser. This file is sourced by /bin/sh from
    # /usr/bin/chromium-browser
    # Options to pass to chromium-browser
    CHROMIUM_FLAGS="--ppapi-flash-path=/usr/lib/chromium-browser/plugins/libpepflashplayer.so --ppapi-flash-version=27.0.0.180"


    不行的话,修改完毕后重启一下电脑。
    回复 支持 反对

    使用道具 举报

    您需要登录后才可以回帖 登录 | 立即注册

    本版积分规则

    小黑屋|手机版|Archiver|Ubuntu Kylin    

    GMT+8, 2018-1-24 15:10 , Processed in 0.203562 second(s), 12 queries , File On.

    Powered by Discuz! X3.3

    © 2013-2018 Comsenz Inc.

    快速回复 返回顶部 返回列表